Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-03-24 09:20:44

"Thorsten Ottosen" <nesotto_at_[hidden]> writes:

> | It's true he made some excellent arguments in that thread, but this is a
> | different argument. ;-) Once you accept as a given that we should be
> | using an ADL customization point, what should we call it?
> |
> | In this message:
> |
> |
> | You say: "You're much safer using boost_range_end or range_end if you're
> | trying to keep it small. I don't see any reason to keep it small,
> | though: users won't be invoking that function directly."
> |
> | And I agree, it should be boost_range_end. We are in agreement. Now we
> | just need to convince Thorsten. :-)
> since we can't use the short version (ity clashes with range_size<TA)
> then let's go with the boost prefix.
> I'll commit shortly

I think you should re-read the boost-users thread and consider all the
issues one more time before you do. This is a hard decision to get

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at