From: Arkadiy Vertleyb (vertleyb_at_[hidden])
Date: 2005-05-06 13:47:30
"Joel de Guzman" <joel_at_[hidden]> wrote
> FWIW, I agree with Dave on this. We should not pretend it's a keyword.
> It's not. Also, Peter noted that the proper spelling for the keyword
> would be "for". So, if we try to follow that, it would have to be
> spelled: "BOOST_FOR", which IMO is a lot better.
Not that I have a strong opinion on this, but I think "for" is not a good
analogy... "For" is something that has "start" statement, end condition,
and "next" statement. "For" is something with two semicolons... It has
much broader meaning.
I think "BOOST_FOREACH" is a perfect name. It's brought from different
languages where it's spelled like this, and should stay this way. "FOREACH"
is short enough and ideomatic enough to be better without underscore.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk