From: Joel de Guzman (joel_at_[hidden])
Date: 2005-05-06 12:53:29
Dave Harris wrote:
> In-Reply-To: <989aceac050505060373e68a1_at_[hidden]>
> caleb.epstein_at_[hidden] (Caleb Epstein) wrote (abridged):
>>>What about the name? Shouldn't it be "BOOST_FOR_EACH"?
>>Why? Because of the distinct English words?
> Yes. And for consistency with other C++ macros, algorithms and keywords.
> I've argued at greater length in the other thread.
FWIW, I agree with Dave on this. We should not pretend it's a keyword.
It's not. Also, Peter noted that the proper spelling for the keyword
would be "for". So, if we try to follow that, it would have to be
spelled: "BOOST_FOR", which IMO is a lot better.
-- Joel de Guzman http://www.boost-consulting.com http://spirit.sf.net