Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-07-11 17:02:40


Hi,

I'm trying to pick good names for the fundamental iostreams components
streambuf_facade and stream_facade:

   template<typename Device ... >
   class streambuf_facade : public basic_streambuf< > {
       // Peform i/o using an instance of Device
   };

   template<typename Device ... >
   class stream_facade : public basic_[i][o]stream< > {
       // Peform i/o using an instance of Device
   };

Here are the candidates:

   1. streambuf_facade / stream_facade
   2. generic_streambuf / generic_stream
   3. streambuf / stream
   4. xstreambuf / xstream
   5. device_streambuf / device_stream
   6. devbuf / devstream

Please let me know what you think.

Jonathan


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk