Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-07-12 16:13:07

Rob Stewart wrote:
> From: "Jonathan Turkanis" <technews_at_[hidden]>

> The "x" was to convey "extended," not "eXperimental."
>> 5. device_streambuf / device_stream
> This is reasonably meaningful given the use of a Device and
> serves to distinguish the names from those in std.

They're hard to pronounce properly, though. I just realized that this is why I
don't like them.

>> 6. devbuf / devstream
> This makes me think of "development" buf/stream.

Yeah, thanks for pointing that out.

But speaking of "buf/stream," how about using "buf" and "stream"? E.g.,

   typedef stream<file> filestream;
   typedef buf<file> filebuf;

   typedef stream<array> arraystream;
   typedef buf<array> arraybuf;

> Thus, I like #5.

Okay, thanks.


Boost list run by bdawes at, gregod at, cpdaniel at, john at