From: Andrey Semashev (andysem_at_[hidden])
Date: 2005-09-23 13:56:23
So, there was a really interesting and hot discussion about namings. Many
opinions were expressed and I'd like to make some roundup. These are the
variants looked most suitable to me as the names of status modification
- arm/disarm. Although, noone have said anything about them, they are still
in the current implementation and look quite applicable.
- activate/deactivate (enable/disable). Other synonims for arm/disarm, a bit
- on/off. The most laconic form. Though, these are not verbs as usually used
for functions. One might think they are some getter functions.
- guard/dismiss. On the on hand, the commonly used "dismiss" should look
familiar. On the other, its meaning is too strong in regard of the function
semantic. The "guard" may be used as well but the word is already frequently
used. Besides, the guard's status enum values' names propably won't
corellate with these words (I just don't see the active status name with
root "guard" - guard::guarding? :( ).
The other versions looked less reflective to me so I didn't include them in
the list. I would be glad if you just vote for one of these positions to
take the final decision.
The make_guarded_call function name seems does not attract that much
attention, so I shall leave it be. Besides, it it possible that I even
remove it from the library, because it can be easily replaced by explicit
"do" functor call and make_guard followed by it.
Unfortunately, nearly no attention have been paid to the implementation
itself, so there's nothing much to roundup here.
PS: Still the question about checking in the library is arisen. The naming
changes are 5 minutes worth, so the final version will be available very
soon with almost no code changes. Will someone want to make a code revision
or may I just gain access and checkin?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk