Boost logo

Boost :

From: Edward Diener (eddielee_at_[hidden])
Date: 2006-04-04 21:42:51

Larry Evans wrote:
> On 04/04/2006 03:33 PM, Edward Diener wrote:
>> I have setup BoostBook on my system following the instructions at Boost
>> in the BoostBook documentation. I attempted to generate documentation
>> for one of the sandbox projects, going to the dandbox project's libs/doc
>> directory and executing bjam --v2 there. I received a message saying
>> that "error: Did not find Jamfile or project-root.jam in any parent
>> directory." But I can clearly see a Jamfile in the sandboxes root
>> directory. Does anybod have any idea what has gone wrong ?
> I had to put a Jamfile.v2 to "connect" my sandbox boost to the "main"
> boost. My directory structure is:
> <main_boost_root>
> bin.v2
> Jamfile.v2 //main Jamfile.v2
> ...
> sandbox
> torjo
> boost-root
> ...
> lje
> Jamfile.v2 //connecting Jamfile.v2
> boost
> fields_visitation
> libs
> fields_visitation
> doc
> Jamfile.v2
> fields_visitation.xml
> The contents of connecting Jamfile.v2 is:
> project boost
> : requirements
> <include>.
> <include>../torjo/boost-root
> : usage-requirements
> <include>.
> <include>../torjo/boost-root
> ;

I tried a Jamfile.v2 of

project boost
      : requirements
      : usage-requirements

in my boost sandbox root directory, but I still received the messages:

error: Could not find parent for project at '../../..'
error: Did not find Jamfile or project-root.jam in any parent directory.

> but I should change that since I'm no longer using torjo's rangelib.
> Anyway, it worked for me now. However, I also remember making some
> changes to boostdoc which allowed building docs in a:
> <boost-root>/libs/<library>/doc
> directory instead of in the:
> <boost-root>/doc
> directory. The changes were described by Joao in post with headers:
> From - Wed Jan 4 04:56:26 2006
> Subject: [Boost-docs] Re: Quickbook Documentation
> Sender: boost-docs-admin_at_[hidden]

I could not find this either in this NG or the boost documentation NG.
Since I have not been allowed to post any questions to the latter, and
since I can not get this to work, I am just going to assume that
BoostBook is broken with v2 of the build system and if it ever gets
fixed in the future I can then try to use it again.

This may be a good example of a technology getting so complicated that
it becomes impossible for even the simplest thing to be done. Sorry to
show my pique but this really should not be so hard to do.

Boost list run by bdawes at, gregod at, cpdaniel at, john at