Boost logo

Boost :

From: Andy Little (andy_at_[hidden])
Date: 2006-06-04 16:37:20

"Pavel Vozenilek" wrote
> Andy Little wrote
>> Pavel Vozenilek wrote
>>> The "t1"s would be hard to maintain in legacy code
>> You mean that :
>> #include <boost/pqs/types/length.hpp>
>> should bring in the (socalled) t1_quantity, t2_quantity for length?.
>> Its worth thinking about, though I do have certain doubts about putting
>> everything in one header. It would make life simpler though. The current
>> hierarchy is noticeably too deep.
> Yes. The "t1" is arbitrary symbol that doesn't make
> much of sense. When someone wants to use the units
> the include path should be intuitive
> #include <boost/si_units/capacitance.hpp>

Thinking about it, that makes much sense and would greatly simplify life for

Thanks for all the info.

Andy Little

Boost list run by bdawes at, gregod at, cpdaniel at, john at