From: Paul A Bristow (pbristow_at_[hidden])
Date: 2006-06-05 09:19:51
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Sebastian Redl
| Sent: 03 June 2006 22:33
| To: boost_at_[hidden]
| Subject: Re: [boost] [Review][PQS] Physical Quantities
| System review (May 31through June 9)
| Pavel Vozenilek wrote:
| >1. The name "pqs" should be changed to
| > something a little bit more descriptive.
| > "unit" feels quite handy.
| "Unit" in programming is closely associated with the
| technique of unit testing,
Most end users, mainly scientists, using it will not have heard of UNIT
testing - just testing
- and they may not do much of that ;-(
| and a library of that name would probably be confused with
| Boost.Test. (See existing libraries like CppUnit.)
Boost.Units is NOT going to be confused with Boost.Test, IMO.
(And Andy cunningly manages to handle non-SI units, vital for the once
Imperial [ now renamed Colonial? ;-) ] units still beloved by the US, so
putting SI in the title won't do at all).
| I like PQS.
I absolutely HATE it! Does conjure up anything except acute acronymitis ;-)
(I also hate the wholey non-descriptive t1_quantity - surely we can do
better than that?)
--- Paul A Bristow Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB +44 1539561830 & SMS, Mobile +44 7714 330204 & SMS pbristow_at_[hidden]
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk