Boost logo

Boost :

From: Paul A Bristow (pbristow_at_[hidden])
Date: 2006-06-05 09:19:51

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Marsh J. Ray
| Sent: 05 June 2006 00:24
| To: boost_at_[hidden]
| Subject: [boost] Infinite precision integer draft (naming)
| Anyone else feel that there might be a better name out there
| for this facility than "Infinite Precision Integer"?

I strongly agree that this is not the best possible name.

| In keeping with the C/C++ traditions of referring to the
| representational size (short, int, long, long long, etc.), another
| approach to might refer to them as "Unsized" integers.

I like "unsized" too, FWIW.


PS I have followed superficially the very long discussion on signed v

I think there is a grave danger of spending so long on this issue that
the opportunity to get the really important signed unsized integers
is missed.

Although unsignedness is sometimes useful,
unlimited size integer are REALLY, REALLY useful.

So I strongly agree with suggestions to stick to just signed for now,
and get some code cut.

Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539561830 & SMS, Mobile +44 7714 330204 & SMS

Boost list run by bdawes at, gregod at, cpdaniel at, john at