Boost logo

Boost :

From: Janek Kozicki (janek_listy_at_[hidden])
Date: 2006-06-12 15:27:59

Andy Little said: (by the date of Sun, 11 Jun 2006 09:29:25 +0100)

> > fixed_quantity,scalable_quantity,free_quantity
> I did think of uni_quantity or universal quantity
> Yes these names make more sense.

of coure those are just my suggestion, you may as well decide to name
them differently. The goal it to GET RID of numbers in names ;)

like this:

rigid_quantity , scaled_quantity , uni_quantity
fully_templated_quantity, partially_templated_quantity, runtime_quantity ;P

whatever. but not numbers :)

> Yes, I should work on this mechanism of using the checked quantities only for
> debugging, but leaving no artefacts of them(like reduced speed) for release. I
> should also work on closing the gap betwen fixed_quantity and floats too though.

I hope that it will work. Or better - that with fixed_quantity the
templates will work so good, that there will be no difference between it
turned on and off.

Janek Kozicki                                                         |

Boost list run by bdawes at, gregod at, cpdaniel at, john at