Boost logo

Boost :

From: me22 (me22.ca_at_[hidden])
Date: 2006-07-25 08:40:37


On 7/25/06, Paul Giaccone <paulg_at_[hidden]> wrote:
> Is "is_infinity" the opposite of "is_finite" or the same as
> "is_plus_infinity"? The former, I would presume, but the name suggests
> the latter. This is the ambiguity I mentioned before. The function would
> be better named "is_infinite", IMO.
>
Agreed.

A few people have mentioned:
> is_plus_infinity()
> is_minus_infinity()
I think positive/negative is better than plus/minus. It's slightly
longer but fits the terminology I understand as being more "correct".
std::plus and std::minus also give a precedent for plus/minus being
operations (addition and subtraction), not classifications for values.

So I'd vote for these instead:
    is_positive_infinity()
    is_negative_infinity()

~ Scott McMurray


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk