Boost logo

Boost :

From: Emil Dotchevski (emildotchevski_at_[hidden])
Date: 2006-08-03 21:52:05


Hello,

I made a minor change in the type registration mechanism from using macros
to this:

struct my_tag: boost::exception_info_tag<int> { };

This update addresses the issue of being able to register tags in
user-defined namespaces. The updated documentation and source code can be
found at

http://www.revergestudios.com/boost-exception/boost-exception.html

It is also possible to extend the interface to support enumeration of the
exception info stored in boost::exception objects, but my personal
preference is to first collect more feedback from people using the library,
because I'm not sure if this enumeration is needed in practice. Brad King
illustrated this idea in his earlier post:

http://article.gmane.org/gmane.comp.lib.boost.devel/146322

I've also received feedback that boost::exception_info would be used fairly
often and needs a shorter name. Maybe boost::xinfo? I hope someone comes up
with a better name.

Finally, I would ask everyone who provided feedback before to please use the
mailing list for that. Having an open discussion is important.

Thanks,
Emil Dotchevski


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk