From: Emil Dotchevski (emildotchevski_at_[hidden])
Date: 2006-08-15 14:04:52
Frank Birbacher wrote:
> Emil Dotchevski schrieb:
>> I've also received feedback that boost::exception_info would be used
>> fairly often and needs a shorter name. Maybe boost::xinfo? I hope
>> someone comes up with a better name.
> Can you change it to boost::exception::info ? Then in functions where
> it's used just do a using boost::exception::info; This makes it short
> type but yet good to read (I hope).
Currently, exception_info is a namespace-scope function template. This fits
best with the rest of the library design. I think it is not a good idea to
change that; I certainly don't like the idea of making it a member of class
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk