Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2006-08-15 14:18:53

Sylvain Pion wrote:
> Thorsten Ottosen wrote:
>>Sylvain Pion <Sylvain.Pion <at>> writes:

> > That said, list_of() is never going to compete with direct aggregrate
> > initialization.
> My point about introducing make_array() was also about syntax.
> The various Boost.Assign variants have poor syntax, imho, even
> if they could be optimized (I haven't looked at their implementation).
> I agree that the best thing would be to have a change in the language.
> But in the mean time, I think introducing make_array() in Boost.Array
> would be nice. I did not get feedback on that.

I agree. I think this should go in the Array library, rather than

Alisdair, do you agree?


Boost list run by bdawes at, gregod at, cpdaniel at, john at