From: Andy Little (andy_at_[hidden])
Date: 2006-09-14 09:39:03
"David Abrahams" <dave_at_[hidden]> wrote in message
> "Andy Little" <andy_at_[hidden]> writes:
>> "David Abrahams" wrote
>>> Joel de Guzman writes:
>>>> advance_iterator looks general enough.
>>> What *is* an advance_iterator?
>> Sequence, // the sequence to advance over
>> Stride, // number of positions in underlying
>> //sequence to move on 'next'
>> StridedPosition, // underlying sequence::position *
>> // Stride + Offset
>> Offset // offset in underlying sequence units
>> The main use is to return a column in a linear sequence representing a
> That's a well-known idea already in the literature;
Its not just an idea. I got one that works with fusion :-)
it's known as a
> "strided iterator." Can we use the common terminology?
OK, but it doesnt sound very cool, compared to advance_iterator. IMO everything
in fusion should have a cool name :-)
Same with inner_product. dot_product is way cooooler.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk