Boost logo

Boost :

From: Manfred Doudar (manfred.doudar_at_[hidden])
Date: 2006-09-14 21:21:16


On Thu, 14 Sep 2006 14:39:03 +0100
"Andy Little" <andy_at_[hidden]> wrote:

>
> "David Abrahams" <dave_at_[hidden]> wrote in message
> news:874pvayao2.fsf_at_pereiro.luannocracy.com...
> > "Andy Little" <andy_at_[hidden]> writes:
> >
> >> "David Abrahams" wrote
> >>> Joel de Guzman writes:
> >>>
> >>>> advance_iterator looks general enough.
> >>>
> >>> What *is* an advance_iterator?
> >>
> >> FWIW:
> >>
> >> fusion::advance_iterator<
> >> Sequence, // the sequence to advance over
> >> Stride, // number of positions in
> >> underlying //sequence to move on 'next'
> >> StridedPosition, // underlying sequence::position *
> >> // Stride + Offset
> >> Offset // offset in underlying
> >> sequence units
> >>>
> >>
> >> The main use is to return a column in a linear sequence
> >> representing a matrix.
> >
> > That's a well-known idea already in the literature;
>
> Its not just an idea. I got one that works with fusion :-)
>
> it's known as a
> > "strided iterator." Can we use the common terminology?
>
> OK, but it doesnt sound very cool, compared to advance_iterator. IMO
> everything in fusion should have a cool name :-)

Though I think this sort of thing would be flushed out in a review,
honestly, when I first read "advance_iterator", I had the same question
pop into my head - what is it?

Admittedly, strided_iterator is a better name, and you get the gist of
its purpose by name alone - can't say that for advance_iterator though.

>
> Same with inner_product. dot_product is way cooooler.

If your dot product is indeed an inner product, then an inner_product
is what you should call your op - being explicit rather than suggestive
is always better (, sorry, just that my mathematics grounding makes me
speak out on this one).

Cheers,

-- 
Manfred Doudar - Research Engineer
National ICT Australia - Canberra Research Lab | www.nicta.com.au
Research School of Information Sciences and Engineering (RSISE)
The Australian National University - Canberra, ACT 0200 AUSTRALIA

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk