Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2006-12-08 17:30:37

"Martin Knoblauch Revuelta" <mkrevuelta_at_[hidden]> writes:

> I tried to build Boost 1.33.1 and the example program with gcc 4.1.2
> in kubuntu 6.10.
> It worked! :-)
> Well, I got some warnings and the final "Not all Boost libraries built
> properly."

Sounds like it didn't work :(

> When I make again, I get:
> ------------------------------------------------------------
> ./tools/build/jam_src/bin.linuxx86/bjam -sPYTHON_ROOT=/usr

Okay, the first thing you need to know is that the version of Boost
you're working with (and in particular, the version of Boost.Build
used by the configure/make scripts) is out-of-date with respect to the
instructions. Please try again with the RC_1_34_0 branch from Boost

> Building Boost.Regex with the optional Unicode/ICU support disabled.
> Please refer to the Boost.Regex documentation for more information
> (and if you don't know what ICU is then you probably don't need it).
> ...found 10626 targets...
> ...updating 24 targets...

OK so far.

> gcc-C++-action bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/bzip2.o
> set -e
> "g++" -c -Wall -ftemplate-depth-255 -g -O0 -fno-inline
> -I"bin/boost/libs/iostreams/build" -I"/home/martin/boost_1_33_1" -I
> "/home/martin/boost_1_33_1" -o
> "bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/bzip2.o"
> "/home/martin/boost_1_33_1/libs/iostreams/build/../src/bzip2.cpp"
> "/usr/bin/objcopy" --set-section-flags .debug_str=contents,debug
> "bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/bzip2.o"
> ...failed gcc-C++-action
> bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/bzip2.o...
> gcc-C++-action bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/zlib.o

Err, there are no GCC error messages in there?
OK, I'm seeing them on my own ubuntu machine. We need to resolve
these issues with the iostreams library build.

> I have no idea what this is all about, but I got to compile, link and
> run the example so... :-)

Well, that doesn't necessarily mean everything's OK. The first
example doesn't depend on any of the libraries building correctly.
The second example only depends on one of the libraries building

> I had a little problem with the libraries: I installed them in
> /usr/local/lib (deafult location, isn't it?), but the system didn't
> find them at runtime.
> I had to append /usr/local/lib to
> /etc/, and then run ldconfig. I decided to do so after
> reading:

OK, I'll look into that and see if I can reproduce it. I don't
actually have an on my machine, so I might need to tell
people to create that file if it doesn't already exist.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at