Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2007-03-01 04:37:19

shunsuke wrote:
> Hi,
> I noticed Range Library Core proposal
> (
> removed 'range_size' metafunction.
> It was replaced by 'range_difference'?
> (But, cvs head is not affected.)

Right. A proposal for the standard and boost is two different things.

> If so, why 'std::size' too is proposed?
> 'std::distance' seems enough.

So that you may have the guarantee that the function is O(1) complexity.


Boost list run by bdawes at, gregod at, cpdaniel at, john at