Boost logo

Boost :

From: shunsuke (pstade.mb_at_[hidden])
Date: 2007-03-01 05:04:08

Thorsten Ottosen wrote:
> shunsuke wrote:
>> Hi,
>> I noticed Range Library Core proposal
>> (
>> removed 'range_size' metafunction.
>> It was replaced by 'range_difference'?
>> (But, cvs head is not affected.)
> Right. A proposal for the standard and boost is two different things.

The 'boost::range_size' of 'iterator_range' is defined as 'std::size_t'.
Can it guarantee to represent any difference_type of iterator?

>> If so, why 'std::size' too is proposed?
>> 'std::distance' seems enough.
> So that you may have the guarantee that the function is O(1) complexity.

'std::distance'(24.3.4/1) also seems to guarantee it?

Shunsuke Sogame

Boost list run by bdawes at, gregod at, cpdaniel at, john at