Boost logo

Boost :

From: Matthias Schabel (boost_at_[hidden])
Date: 2007-03-30 13:07:09

>> I prefer quantity_reinterpret_cast myself - more time to think while
>> you're typing...
> I don't think the name matters from a safety
> perspective. How likely is someone to accidently
> use a cast, especially if it only has a single
> meaning? Also, extracting the value type is,
> IMO, safer than static_cast and const_cast because
> those can produce a value that is incorrect to
> use at all.

Good point - I'm OK with having a single well-defined quantity_cast,
eliminating the other use cases and eliminating
quantity_reinterpret_cast - for the latter, users might just as well
use the built-in reinterpret_cast...


Boost list run by bdawes at, gregod at, cpdaniel at, john at