Boost logo

Boost :

From: Steven Watanabe (steven_at_[hidden])
Date: 2007-03-29 21:45:51


Matthias Schabel <boost <at>> writes:

> > I could certainly live with that, though I'd prefer something that
> > sounds a little more ... dangerous. :)
> I prefer quantity_reinterpret_cast myself - more time to think while
> you're typing...

I don't think the name matters from a safety
perspective. How likely is someone to accidently
use a cast, especially if it only has a single
meaning? Also, extracting the value type is,
IMO, safer than static_cast and const_cast because
those can produce a value that is incorrect to
use at all.

In Christ,
Steven Watanabe

Boost list run by bdawes at, gregod at, cpdaniel at, john at