Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2007-04-29 00:01:12


Eric Niebler wrote:
> Maurizio Vitale wrote:
>> What is the rationale for not having proto::tags match the corresponding
>> mpl metafunctions?
>>
>> For instance mpl has plus and proto has add (but unary_plus).
>
> Oh my. You're right, that's awful. I'll fix these.

I've changed the names of some types in proto to bring it in line with
conventions established in <functional> and Boost.MPL. This should
affect just about everybody currently using proto. In particular:

proto::multiply -> proto::multiplies
proto::divide -> proto::divides
proto::add -> proto::plus
proto::subtract -> proto::minus
proto::equal -> proto::equal_to
proto::not_equal -> proto::not_equal_to
proto::unary_plus -> proto::posit
proto::unary_minus -> proto::negate
proto::unary_star -> proto::dereference
proto::multiply_assign -> proto::multiplies_assign
proto::divide_assign -> proto::divides_assign
proto::add_assign -> proto::plus_assign
proto::subtract_assign -> proto::minus_assign

The corresponding tag types have also changed accordingly. For the
complete list of tags, see:
<http://boost.cvs.sourceforge.net/boost/boost/boost/xpressive/proto/tags.hpp?view=markup>

The docs, tests and examples have been updated to reflect the new names.
Get the latest from CVS, or from proto.zip in the Vault.

-- 
Eric Niebler
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk