Boost logo

Boost :

From: dan marsden (danmarsden_at_[hidden])
Date: 2008-02-06 02:21:17


Larry Evans <cppljevans_at_[hidden]> wrote: <snip exampling showing make list returns a cons cell list, rather than fusion::list> >IOW, instead of: > > boost::fusion::vector<...> > >there should be: > > boost::fusion::list<...> > >as the 1st line of the above result type for as_list<source_type>::type. Does this lead to a problem in your code? The sequence of cons cells is a list (fusion::list can be seen as just a convenient way of building a long cons cell sequence). The cons sequence will behave exactly as a list. Maybe these functions should be called as_random_access_sequence, as_bidirectional_sequence etc? Possibly that would be less misleading? Cheers Dan ___________________________________________________________ Support the World Aids Awareness campaign this month with Yahoo! For Good http://uk.promotions.yahoo.com/forgood/


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk