From: Marcus Lindblom (macke_at_[hidden])
Date: 2008-05-22 04:21:20
John Femiani wrote:
> How about deprecating branch_path and using 'head', and deprecating
> 'leaf' in favor of 'tail'? This replaces tree terms with list terms,
> since a path is a list.
The way I'm used to name lists (from Haskell and others), is that a
list of x has a head of type x and a tail of type 'list of x'.
Your version would turn that around, which would confuse me.
I have no problem in seeing leaf() as the last element in the path
(which is a list of names) and it's short and sweet. If one can accept
that the path is a different concept from the file entry, this works
I think there are valid arguments for and against, and I'd hate to have
this switched at this moment, when it's been used for quite a while by
many apps. There are too many things changing from one boost release to
another already, so you'd better make a good argument and have a clear
concensus. (We're getting dangerously close to the bike-shed... :)