Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2008-05-22 19:58:59

on Wed May 21 2008, Larry Evans <> wrote:

> On 05/21/08 08:48, Zach Laine wrote:
> > On Wed, May 21, 2008 at 8:44 AM, Frank Mori Hess wrote:
> >> On Wednesday 21 May 2008 09:34 am, Zach Laine wrote:
> >>> This sheds their context. The linear sequence does not exist in a
> >>> vacuum. It is a sequence of nodes that defines a path through a
> >>> filesystem tree. When I think of a filesystem, I think of it as
> >>> (a) root node(s), interior nodes, and leaf nodes. The fact that
> >>> I'm only looking at a subset of them when dealing with a given
> >>> path does not change what kind of node each is conceptually. In
> >>> short, I like "leaf()".
> >> My impression from earlier posts, and the path decomposition table
> >> in the docs, is that leaf is a bad name because it can return an
> >> interior node in the filesystem.
> > Then the leaf referred to is still the leaf of a subtree of the
> > filesystem. I'm as into proper naming as the next guy. The point
> > I'm trying to get across is that the name "leaf()" seems very
> > natural to me. In fact, it has never given me a moment's pause.
> Would the term "pruned_leaf" be an acceptable compromise?

Bleah; that's just more complicated and less evocative of what's
actually going on. Just use the darned name that everyone else uses!
Or, if you *really* can't stand "basename()", at least use a word that's
conceptually appropriate like "tail()" or, heck, "back()"

Dave Abrahams
BoostPro Computing

Boost list run by bdawes at, gregod at, cpdaniel at, john at