Date: 2008-05-27 08:59:00
Beman Dawes <bdawes_at_[hidden]> writes:
> Sean Hunt wrote:
>> Jumping in at this point in the conversation, why not just define the
>> BOOST_NO_* macros and define the BOOST_HAS_* as being !BOOST_NO_*. That
>> way we get both?
> That's an interesting idea, although perhaps a little to cute. What do
> others think? Does it add value or just confuse?
Well, for one thing it would mean that those of us who have started to
use the BOOST_HAS_ variants won't suddenly find our code broken.
-- Anthony Williams | Just Software Solutions Ltd Custom Software Development | http://www.justsoftwaresolutions.co.uk Registered in England, Company Number 5478976. Registered Office: 15 Carrallack Mews, St Just, Cornwall, TR19 7UL
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk