Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2008-05-27 08:35:11


Sean Hunt wrote:
> Beman Dawes wrote:
>> OK, I propose to add the following:
>>
>> // Rename versions some current BOOST_HAS_* macros to:
>>
>> BOOST_NO_CONCEPTS
>> BOOST_NO_DECLTYPE
>> BOOST_NO_LONG_LONG
>> BOOST_NO_RVALUE_REFS
>> BOOST_NO_STATIC_ASSERT
>> BOOST_NO_VARIADIC_TMPL
>>
>> // New macros:
>>
>> BOOST_NO_SCOPED_ENUMS // no enum class
>> BOOST_NO_RAW_LITS // no raw character or string literals
>> BOOST_NO_UNICODE_LITS // no Unicode literals
>> BOOST_NO_OX_CHAR_TYPES // no char16_t or char32_t
>> BOOST_NO_EXPLICIT_CVT_OP // no explicit operator T()
>> BOOST_NO_DFLT_AND_DEL_FUNCS // no = default or = delete functions
>> BOOST_NO_CONSTEXPR // no constexpr
>>
>> Comments or suggestions?
>>
>> --Beman
>
> Jumping in at this point in the conversation, why not just define the
> BOOST_NO_* macros and define the BOOST_HAS_* as being !BOOST_NO_*. That
> way we get both?

That's an interesting idea, although perhaps a little to cute. What do
others think? Does it add value or just confuse?

Thanks,

--Beman


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk