Boost logo

Boost :

From: Isaac Dupree (isaacdupree_at_[hidden])
Date: 2008-08-15 19:38:32

David Abrahams wrote:
>> But do you have a better suggestion? What about just renaming the
>> function to "call_swap(T&,T&)"? Because that's what it does: it just
>> calls the most appropriate swap function.
> Or, you might say that it "swaps" its arguments. Hey, maybe we should
> call it swap(T&,T&)!

either "call_swap" or "swap" seems fine with me; I think
call_swap specifies the purpose nicely amongst all the ways
to call "swap". But likely it's good enough to leave the
rationale for having a "boost::swap" for readers to look-up
in the Boost documentation, too.

On the possibility of calling specific overloads for
swapping boost types directly, iff we name it "swap": is
there any compiler where that actually makes a difference?


Boost list run by bdawes at, gregod at, cpdaniel at, john at