Boost logo

Boost :

Subject: Re: [boost] [mp_int] new release
From: Scott McMurray ([hidden])
Date: 2008-10-08 23:25:23

On Wed, Oct 8, 2008 at 22:33, Kevin Sopp <baraclese_at_[hidden]> wrote:
> My plan was to call a fixed precision integer fp_int. I think it's a
> good idea to keep the name short for such a basic arithmetic type. I
> can make it clearer in the introduction that mp_int stands for
> multiple precision integer which grows dynamically in size / has
> unbounded precision. I really like the name mp_int, I would accept
> ap_int though.

"Choose meaningful names - explicit is better than implicit, and
readability counts. There is a strong preference for clear and
descriptive names, even if lengthy."

People can always typedef unbounded_int<> mp_int; if they want to.
(I'd probably use a typedef anyways, since I find <> everywhere
aesthetically distasteful.)

Kim Barrett's suggestion of just calling it integer is rather nice.
Especially if integer<> were integer<unbounded> and it were also
possible to specify integer<bounded<256> >, for example. (Or
infinite/fixed, or ...)

I downloaded it and played a bit; everything seemed intuitive enough.

There's an interesting project for someone to expression template it, too =)

Boost list run by bdawes at, gregod at, cpdaniel at, john at