Boost logo

Boost :

Subject: Re: [boost] [mp_int] new release
From: Kevin Sopp (baraclese_at_[hidden])
Date: 2008-10-08 22:33:43

>>How about unbounded_int? It fits nicely with the is_bounded
>>in numeric_limits.
> So are you proposing two names:
> bounded_int - arbitrary but fixed (maximum?) size integer
> unbounded_int - grows to accommodate a size (bounded only by machine memory).

My plan was to call a fixed precision integer fp_int. I think it's a
good idea to keep the name short for such a basic arithmetic type. I
can make it clearer in the introduction that mp_int stands for
multiple precision integer which grows dynamically in size / has
unbounded precision. I really like the name mp_int, I would accept
ap_int though.

Boost list run by bdawes at, gregod at, cpdaniel at, john at