Boost logo

Boost :

Subject: Re: [boost] [mp_int] new release
From: Paul A Bristow (pbristow_at_[hidden])
Date: 2008-10-09 05:20:41


>-----Original Message-----
>From: boost-bounces_at_[hidden]
>[mailto:boost-bounces_at_[hidden]] On Behalf Of Kevin Sopp
>Sent: 09 October 2008 03:34
>To: boost_at_[hidden]
>Subject: Re: [boost] [mp_int] new release
>>>How about unbounded_int? It fits nicely with the is_bounded
>>>in numeric_limits.
>> So are you proposing two names:
>> bounded_int - arbitrary but fixed (maximum?) size integer
>> unbounded_int - grows to accommodate a size (bounded only by
>machine memory).
>My plan was to call a fixed precision integer fp_int. I think it's a
>good idea to keep the name short for such a basic arithmetic type. I
>can make it clearer in the introduction that mp_int stands for
>multiple precision integer which grows dynamically in size / has
>unbounded precision. I really like the name mp_int, I would accept
>ap_int though.

I really, really don't like any of these names :-(

fp_int sounds something to do with Floating Point (nonsense of course ;-)

mp_int doesn't say anything obvious to me.

Neither seem to me to meet Boost's preference for "Clarity before curtness".

I think it must be really obvious if the type is bounded/fixed, or will grow.
It's not for the writers - it's for the *readers* of programs who need to know immediately what sort of fancy integer beast is being
used (without RTFM).

Ideally, a Boost library should at least fix the naming for both types, and the structure too?


Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539561830 & SMS, Mobile +44 7714 330204 & SMS

Boost list run by bdawes at, gregod at, cpdaniel at, john at