Subject: Re: [boost] Proposal/InterestCheck: Boost.Geom
From: Barend Gehrels (barend_at_[hidden])
Date: 2009-01-29 12:38:57
> My purpose is to make the indirect approach as/more readable and convenient
> as the direct one so that the user's won't have to tie their code to the
> underlying framework's points and boxes (i.e they won't have to deal directly
> with QPoints at all).
It is probably possible to add such an approach on top of a library like
ours. However, didn't have this use case before.
> It seems that your purpose is rather: Provide lots of algorithms and make them
> applicable to any type the user is currently working with (the user will still
> have to know/use QPoints before passing them to the algotithms).
Yes. We don't wrap. Correct.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk