Subject: Re: [boost] Review Request: Introduction of boost::string namespace and string-conversion functions
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2009-02-13 07:40:18
Ilya Sokolov wrote:
> In most cases names does not change when moved to std::.
> The name 'boost::string' would suggest a string class for me, not a
> namespace. boost::strings, boost::text,
> boost::from_string/boost::to_string seems much better to me.
I tend to agree on thinking of a string as a class. Given Vladimirs
section-headers in his message,
>> 3. Naming of the conversion functions.
>> 4. String-To-Something Conversion Interface.
>> 6. Something-To-String Conversion Interface.
>> 7. Check-Convertibility Interface.
perhaps the namespace "convert" would be appropriate.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk