Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2009-02-26 07:33:05
Neil Groves wrote:
> So is everyone happy if I:
> 1. Change the 'ed' adaptors to _view
I wouldn't be too happy about it.
The lazy adaptors being preferred over the eager in-place algorithms,
the name of the adaptors should be as short as possible, especially
since chaining of adaptors can lead to fairly long expressions.
> 2. name the operator | alternatives with the same name as the adaptor?
Sure, that's good.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk