Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Neil Groves (neil_at_[hidden])
Date: 2009-02-25 16:15:08
On Wed, Feb 25, 2009 at 9:07 PM, Thorsten Ottosen <
> vicente.botet skrev:
> As unique exist already, what about unique_view. With the _view suffix we
>> state clearly that the evaluation is lazy.
> Just to make sure there is no confusion on this point, then the orignal _ed
> suffix was supposed to mean "lazy". That doesn't mean it is perfect naming
> scheme, of course.
I strongly prefer the _view suffix. I wish I had thought of it before the
So is everyone happy if I:
1. Change the 'ed' adaptors to _view
2. name the operator | alternatives with the same name as the adaptor?
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk