Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Neil Groves (neil_at_[hidden])
Date: 2009-02-26 07:41:21
On Thu, Feb 26, 2009 at 12:33 PM, Mathias Gaunard <
> Neil Groves wrote:
> So is everyone happy if I:
>> 1. Change the 'ed' adaptors to _view
> I wouldn't be too happy about it.
> The lazy adaptors being preferred over the eager in-place algorithms, the
> name of the adaptors should be as short as possible, especially since
> chaining of adaptors can lead to fairly long expressions.
I'm not going to do this change. It appears that more people are happy with
the current 'ed' ending than a '_view' ending. I don't have a strong opinion
at all on this issue, but it's clear the majority prefer 'ed'. It's great to
have reviewers so I can stop guessing.
> 2. name the operator | alternatives with the same name as the adaptor?
> Sure, that's good.
This is already done, but some people strongly dislike the make_XXX_range
syntax. It has been proposed to make it the function that creates the
adaptor the same name as the adaptor itself. This should work, but I can't
quite get comfortable with this idea. Does anyone else share my concern that
there might be confusion by sharing the same name? My current impression is
that most reviewers would prefer the same name. I wonder if some people are
being quiet. Perhaps using 'uniqued' for the adaptor and 'unique_view' for
the function version would be acceptable?
Please can I invite comments with regard to the operator | and alternative
naming. I currently don't feel that we have reached a broadly acceptable
agreement on this issue.
Thank you all for your reviews.
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk