Subject: Re: [boost] [range][rangex] Joining two unrelated ranges?
From: Neil Groves (neil_at_[hidden])
Date: 2009-06-24 03:53:52
A small comment inviting new discussion on RangeEx naming is inline:
On Wed, Jun 24, 2009 at 1:52 AM, Joel de Guzman
> Mathias Gaunard wrote:
>> Joel de Guzman wrote:
>> In Fusion (and also in MPL), it's called joint_view:
>>> and there's the fusion::join algo:
>>> If anyone writes such a thing (I'm surprised RangeEx does not have it),
>>> please follow MPL/Fusion's lead.
>> I'm not sure an agreement was reached during review as to what naming to
>> use for "lazy" range operations.
>> According to the initial naming convention RangeEx used, it would be
>> called "joined" and not "join_view".
> Sigh, yeah, I recall the review. I'll just hope the people involved
> will value precedence and consistency.
If there was something about the review that you did not like, could we
please attend to it by finding useful actions? I'm more than happy to
evaluate/accomodate everyone's input. There was not much discussion IIRC
when I discussed using join_view, join, or joined. I am concerned that the
tone of the comment indicates a broader dissatisfaction. I would be happy to
discuss specific points and attempt to resolved any issues you may have.
> Joel de Guzman