Boost logo

Boost :

Subject: Re: [boost] [range][rangex] Joining two unrelated ranges?
From: Joel de Guzman (joel_at_[hidden])
Date: 2009-06-24 05:19:32

Neil Groves wrote:
> A small comment inviting new discussion on RangeEx naming is inline:

>>> According to the initial naming convention RangeEx used, it would be
>>> called "joined" and not "join_view".
>> Sigh, yeah, I recall the review. I'll just hope the people involved
>> will value precedence and consistency.
> If there was something about the review that you did not like, could we
> please attend to it by finding useful actions? I'm more than happy to
> evaluate/accomodate everyone's input. There was not much discussion IIRC
> when I discussed using join_view, join, or joined. I am concerned that the
> tone of the comment indicates a broader dissatisfaction. I would be happy to
> discuss specific points and attempt to resolved any issues you may have.

I'm not eager to argue about naming. We can argue till death but
still have a deadlock. Such are subjective issues and it's a
matter of preference. Yet, above preference, there is also
consistency and precedence. It's just a fact that MPL and Fusion
came *before* RangeEx and it's also a fact that we have something
in common: views. It's also a fact that STL came before. Much as
I hate the name "find_if", for example, I value STL's precedence
and I can't just replace Fusion's counterpart for something
"better". And then of course, there's consistency -- with Boost
-- MPL/Fusion calls it join (the function) and joint_view (the
sequence/view). I fail to see any reason why RangeEx will have to
break this consistency.

Anyway, I consider this a bike-shed issue and so I leave it at
that. Que Sera, Sera :-)


Joel de Guzman

Boost list run by bdawes at, gregod at, cpdaniel at, john at