Subject: Re: [boost] [range][rangex] Joining two unrelated ranges?
From: Rogier van Dalen (rogiervd_at_[hidden])
Date: 2009-06-24 06:12:54
On Wed, Jun 24, 2009 at 08:53, Neil Groves <neil_at_[hidden]> wrote:
> On Wed, Jun 24, 2009 at 1:52 AM, Joel de Guzman
> > Mathias Gaunard wrote:
> >> I'm not sure an agreement was reached during review as to what naming to
> >> use for "lazy" range operations.
> >> According to the initial naming convention RangeEx used, it would be
> >> called "joined" and not "join_view".
> > Sigh, yeah, I recall the review. I'll just hope the people involved
> > will value precedence and consistency.
> If there was something about the review that you did not like, could we
> please attend to it by finding useful actions? I'm more than happy to
> evaluate/accomodate everyone's input. There was not much discussion IIRC
> when I discussed using join_view, join, or joined. I am concerned that the
> tone of the comment indicates a broader dissatisfaction. I would be happy to
> discuss specific points and attempt to resolved any issues you may have.
I think I might have mentioned my opinion. Since I think lazy views
should be the main mode of operation, I think they ideally should have
the shortest name, "join". That happens to coincide with Joel's view
from consistency with MPL/Fusion. The issue with this may be
RangeEx-internal consistency. You may need to give different types of
operations (mutating, lazy functions, lazy operator| ) different
names. But it's a bike shed discussion: three keystrokes more or fewer
doesn't make a whole lot of difference. I think everyone assumes you
will come up with something sensible.
On a more constructive note, I don't think the joint_view_iterator (or
another name) that you'll need is in Boost yet. I do have one lying
around (which takes a tuple of iterators) that I'd be happy to
contribute. Just drop me an email.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk