Boost logo

Boost :

Subject: Re: [boost] sorting library proposal (Was: Review Wizard Status Report for June 2009)o
From: Steven Ross (spreadsort_at_[hidden])
Date: 2009-08-19 19:42:10


On Wed, Aug 19, 2009 at 11:26 AM, DE <satan66613_at_[hidden]> wrote:

> > I don't see how it hurts, so I implemented your suggestion; the constants
> > are now defined as enum { val = # }, instead of having a type. Thanks
> for
> > your feedback.
> well actually i meant that you can define all constants in one unnamed
> enum like
>
> enum {
> MAX_SPLITS = 11,
> MAX_FINISHING_SPLITS = MAX_SPLITS + 1,
> LOG_MEAN_BIN_SIZE = 2,
> LOG_MIN_SPLIT_COUNT = 9,
> LOG_FINISHING_COUNT = 31,
> FLOAT_LOG_MEAN_BIN_SIZE = 2,
> FLOAT_LOG_MIN_SPLIT_COUNT = 8,
> FLOAT_LOG_FINISHING_COUNT = 4,
> MIN_SORT_SIZE = 3000
> };
> <http://lists.boost.org/mailman/listinfo.cgi/boost>
>

Is there any reason why one approach (unnamed enum for each value vs. single
unnamed enum for all) is better than the other?


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk