Boost logo

Boost :

Subject: Re: [boost] Looking for a name for a Subjet-Entity-Role library
From: vicente.botet (vicente.botet_at_[hidden])
Date: 2009-10-05 06:47:26

----- Original Message -----
From: <joaquin_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Monday, October 05, 2009 12:29 PM
Subject: Re: [boost] Looking for a name for a Subjet-Entity-Role library

Joachim Faulhaber escribió:
> 2009/10/5 Vicente Botet Escriba <vicente.botet_at_[hidden]>:
>> If the namespace is role, and as I have a role class, is
>> the following readable
>> class Employee: public boost::role::role<Employee, PersonRole>?
> Smart as you are you found a tiny drawback of the name.
> Well yes, readability suffers a little bit. But this is the *only*
> class name that is affected by this repetition effect.
> I could easily live with that...
> ... or you choose ...
> Boost.Roles
> The Boost *R*ole *O*bject *L*ibrari*es*
> Ha!
> class Employee: public boost::roles::role<Employee, PersonRole>

According to Boost naming guidelines, the natural choice would be Boost.Role
for the lib name and boost::roles as the associated namespace. That is, the
suffixed s only goes to the namespace, not the lib name:

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo
Unsubscribe & other changes:

Thanks to both. I will take Role as library name, roles as namespace (even if I have a class named roles to list the roles of a subject, I could rename it to role_list or something else.

Thanks again,

Boost list run by bdawes at, gregod at, cpdaniel at, john at