Subject: Re: [boost] Name of namespace detail
From: Jean-Louis Leroy (jl_at_[hidden])
Date: 2009-10-12 19:34:14
> I use detail name myself. Any better names for bucket with
> implementation details?
What about `namespace private_` ? Even if access won't be controlled by
the compiler. And also a `namespace protected_` if there are useful
things to put there ?
Btw fusion has an `extension` namespace in addition to `detail`. It
seems to play the same role as protected interfaces in class hierarchies.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk