Boost logo

Boost :

Subject: Re: [boost] Name of namespace detail
From: Mateusz Loskot (mateusz_at_[hidden])
Date: 2009-10-12 19:57:16

Jean-Louis Leroy wrote:
>> I use detail name myself. Any better names for bucket with
>> implementation details?
> What about `namespace private_` ? Even if access won't be controlled
> by the compiler.

That's my favourite replacement. The underscore suffix in name could be
easily linked with quite popular use of it in naming private class members:

struct T
   int value_;
   int foo_() { ... }

> And also a `namespace protected_` if there are useful things to put
> there ?

Doesn't really work for me. If something is useful (assuming for a
library client), put it to public namespace. Second would be too much,
convention became too complex, so vague. I think.

Best regards,

Mateusz Loskot,
Charter Member of OSGeo,

Boost list run by bdawes at, gregod at, cpdaniel at, john at