Subject: Re: [boost] Name of namespace detail
From: Stefan Strasser (strasser_at_[hidden])
Date: 2009-10-19 20:41:30
Am Tuesday 13 October 2009 01:57:16 schrieb Mateusz Loskot:
> Jean-Louis Leroy wrote:
> >> I use detail name myself. Any better names for bucket with
> >> implementation details?
> > What about `namespace private_` ? Even if access won't be controlled
> > by the compiler.
> That's my favourite replacement.
how is "private" more meaningful than "detail"?
private is a keyword defined by c++. detail is a namespace defined by boost.
both names aren't meaningful or descriptive unless you know their definition.
(.NET actually uses "private" and "public" and enforces it)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk