Boost logo

Boost :

Subject: Re: [boost] enable_shared_from_this2
From: Gottlob Frege (gottlobfrege_at_[hidden])
Date: 2009-10-28 11:10:49

On Tue, Oct 27, 2009 at 8:42 PM, Peter Dimov <pdimov_at_[hidden]> wrote:
> Frank Mori Hess wrote:
>> Hash: SHA1
>> On Tuesday 27 October 2009, Peter Dimov wrote:
>>> (How about
>>> 'shared_from_raw' as a name for the free function?)
>> That's fine by me.  I also like shared_from_pop (pop == plain old
>> pointer) although that might be more obscure.
> OK, to get back to your earlier question, I consider you the 'owner' of
> enable_shared_from_this2, so feel free to fix it whichever way you want. :-)

Fix it "whatever way you want" :-), but call it _raw, not _pop -- as a
user, I'd only understand the first one.


Boost list run by bdawes at, gregod at, cpdaniel at, john at