Subject: Re: [boost] [unordered] unordered_set::erase() complexity bug?
From: OvermindDL1 (overminddl1_at_[hidden])
Date: 2009-11-28 23:39:56
On Sat, Nov 28, 2009 at 3:52 PM, John Zwinck <jzwinck_at_[hidden]> wrote:
> Daniel James wrote:
>> 'erase' would be better. But as a temporary measure I'll add something
>> like that, you might want to file a ticket to make sure I don't forget
>> and track what I do.
> I have created a ticket: https://svn.boost.org/trac/boost/ticket/3693
Instead of making a new function name, why not a function overload:
iterator erase(iterator it); // original
void erase(iterator it, no_return); // no_return is an empty global
created struct so you can just call m.erase(it, no_return);