Boost logo

Boost :

Subject: Re: [boost] [Review] ITL review starts today, February 18th
From: Daniel Trebbien (dtrebbien_at_[hidden])
Date: 2010-02-28 12:25:55

> During the review period I had a discussion on the list with Joachim
> about the operators and the naming of functions. However, I thought that
> the += and |= were both doing a pure union, but it appears that they are
> doing a union PLUS a (sometimes mathematic) addition. So my current
> opinion is:
> For sets (o.a. interval_set), the following operators are appropriate,
> as also used in Boost.dynamic_bitset:
> &= for intersection
> |= for union
> ^= for symmetric difference
> -= for difference
> So this is how it is implemented but I would remove += as a synonym for |=
> For interval_map, it is currently much less clear to me now. The
> operators do two things at the same time, which is confusing me. ...

I won't be able to review ITL, but I would like to comment that I
think that this issue of operators needs to be resolved before ITL is
included in Boost.

Boost list run by bdawes at, gregod at, cpdaniel at, john at