Subject: Re: [boost] [Review] [ITL] ITL formal review results
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2010-04-29 08:08:55
> -----Original Message-----
> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of Joachim Faulhaber
> Sent: Monday, April 19, 2010 2:51 PM
> To: boost_at_[hidden]
> Subject: Re: [boost] [Review] [ITL] ITL formal review results
> >> Last but not least people suggested to change the name of the library as
> >> having the word template in the name does not carry any useful information.
> >> Joachim already agreed to this.
> > But did I miss discussion (or a conclusion) about what it *should* be called?
> > We already have Boost.Interval which handles interval arithmetic, so it can't be that.
> > So is this going to be called Boost.Intervals (sniffs ;-) or what?
> Currently I tend to use the name that has been used for the objects of
> the library already by various people including myself because it is
> kind of "natural":
> Boost.IntervalContainer (library name)
> boost::interval_container (namespace)
FWIW both look OK to me. Clarity is better than curtness.
> Because I hate long namespace identifiers, I think I will use a kind
> of standard namespace alias
> namespace icl = boost::interval_container;
> so that 'itl' can be replaced by 'icl' without spoiling the current program code.
(not quite sure you need the final 'l', but it's the users choice of shorthand).
--- Paul A. Bristow Prizet Farmhouse Kendal, UK LA8 8AB +44 1539 561830, mobile +44 7714330204 pbristow_at_[hidden]
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk