Subject: Re: [boost] [gsoc][RFC] Pointer Plus Bits
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-07-27 11:18:51
Brian Bartman wrote:
> As it is currently bitfield_tuple is in the boost namespace
Why is that?
> and extra parts external to the class are located within
> the bitfields namespace.
Presumably, bitfield_tuple is defined in the your nested namespace and brought into the boost namespace with a using declaration. (I haven't looked.)
> One of the other names which came up for this data structure
> was bit_tuple does that sound any better?
I don't think that's good. It isn't a tuple of bits, but rather of arbitrarily grouped bits. Hence "bit_field_tuple" is the better name.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk